Installing Linux version of Dash

General questions and discussions focused around the EKM Metering System. Discuss your meters, installations, and meter communications here.
Post Reply
Posts: 4
Joined: Wed Oct 22, 2014 4:59 pm

Installing Linux version of Dash

Post by marc »

Hi everyone. I hope someone can provide some help with this.
I have an EKM water meter system set up with water meters going to an EKM Omnimeter Pulse v.4, then to a EKM Blink - RS-485 to USB Converter, and finally to a Linux computer running Dash. The problem is probably that I am not familiar enough with Linux.
Everything seems to be working except I am having trouble installing EKM Dash on my Linux computer to read and control the Omnimeters.

*** Every time I try to “Start Reading” on Dash, the “Activity” reading shows as: “Bad Connection to USB or RS-232 Converter”. ***
I get this same error reading whether the Converter is plugged in or not.

My computer setup is:
Eee PC Intel Atom CPU N280 @ 1.66GHz
305GB Hard Drive, Memory 1Gb
(also tried everything on an HP Pentium 4 with a 120GB Hard Drive and Memory 512MB)
On both computers I tried running Dash on Linux Mint 17 “Qiana” Cinnamon 32-bit version 2.2.13 based on Ubuntu 14.04 and also on the latest versions of Ubuntu and Lumbutu.

I had the same problem no matter which version of Linux I used and no matter which of the two computers I used.
I also tried using the “EKM Blink - RS-485 to USB Converter” on a Windows 8.1 computer running the Windows version of Dash and it worked fine so I know the problem is not the “EKM Blink - RS-485 to USB Converter”.

Here is the installation procedure I used for installing Dash on Linux. I downloaded and unzipped “EKM Metering Dash v1.5.1 (trial version)” from the EKM website. That resulted in an executable file “EKM Dash” and a folder “EKM Dash Libs” in my downloads folder. (I also tried everything with the files on the Desktop instead of the Downloads folder to see if that was the problem but that did not matter)
To start with when I clicked on the “EKM Dash” executable file it would start to open and then close right away. After that I ran the Linux command “sudo apt-get install libwebkit-dev” and I was able to run Dash on my computers.
I plugged the “EKM Blink - RS-485 to USB Converter” into the computer’s USB port. From the Dash program I am then able to go to “Add Meter” and select “EKM-Omnimeter Pulse v.4” and “USB Serial Port: /dev/ttyUSB0”.

I also verified that the driver was installed (I think) by typing in the Linux terminal window “ dmesg | grep FTDI <ret> “ which then says:

marc@marc-1000HE ~ $ dmesg | grep -i ftdi
[ 574.330325] usb 3-1: Manufacturer: FTDI
[ 574.447816] usbcore: registered new interface driver ftdi_sio
[ 574.447883] usbserial: USB Serial support registered for FTDI USB Serial Device
[ 574.448730] ftdi_sio 3-1:1.0: FTDI USB Serial Device converter detected
[ 574.459382] usb 3-1: FTDI USB Serial Device converter now attached to ttyUSB0

I also tried to get information on the driver with the command “modinfo ftdi_sio”, which output:
filename: /lib/modules/3.13.0-37-generic/kernel/drivers/usb/serial/ftdi_sio.ko
license: GPL
description: USB FTDI Serial Converters Driver
author: Greg Kroah-Hartman <>, Bill Ryder <>, Kuba Ober <>, Andreas Mohr, Johan Hovold <>
. . .
Usbserial intree: Y
vermagic: 3.13.0-37-generic SMP mod_unload modversions 686
signer: Magrathea: Glacier signing key
sig_key: 7A:CF:8E:D9:48:D7:7B:6A:80:F2:4F:59:D5:D8:ED:03:87:AA:B4:26
sig_hashalgo: sha512
parm: ndi_latency_timer:NDI device latency timer override (int)

I also tried to access the Virtual COM port in Ubuntu by removing the “brltty” port using the command: sudo apt-get remove brltty <CR>

Nothing I do seems to make it work! :|
Post Reply