TCP Socket Failed to Connect

General questions and discussions focused around the EKM Metering System. Discuss your meters, installations, and meter communications here.
Post Reply
Wouter
Posts: 11
Joined: Sun May 20, 2012 11:37 am

TCP Socket Failed to Connect

Post by Wouter » Thu May 24, 2012 6:53 pm

I've hooked up the iserial device to my Omni Meter v.3.

I can connect to the iserial to on http://192.168.1.125/. I've adjusted the setting as per the instructions.

The software is able to read meter 123 - Omni test meter. It sometimes reads the second one. However, I constantly get TCP Socket failed to connect dialog popping up.

I can not get it to read my meter.

I am using Windows 7 764 bit.

Thanks,


Wouter

Jameson
Posts: 770
Joined: Fri Nov 04, 2011 7:42 pm
Location: Santa Cruz, CA
Contact:

Re: TCP Socket Failed to Connect

Post by Jameson » Fri May 25, 2012 12:23 pm

Hello Wouter,

The "Complete Guide to EKM Metering is a good place to start: http://www.ekmmetering.com/information/ ... guide.html

There is a section for software. Also stay tuned for our next version of the software, we hope to have this in a couple months.


I will go over it with you here:

This is for help with Free Version or Paid Version of the EKM Reader Software v.3 This version does have some strange interactions with Windows 7 (it works well for some and not well for others)

It sounds like you have our meters here at EKM still in your software. They are there for demonstration purposes.

:arrow: :arrow: :arrow: :arrow: :arrow:

1. Lets first erase the demo meters and put in your own meter information:

In the main window of the EKM Reader software select the line where the demo meters are in the lower listbox. Select the Meter number and change it to your meter number. Your meter number is laser marked into the face of your meter.

You can select an entire row and delete it by hitting "backspace" or "delete" depending on your system. If you need a new row go up to "Edit" and select "Add Row Below"

2. Go to "Preferences" in the menu bar at the top of the page.

Select "COM Port Setup"

Enter your Communication Device details.

Go to line 3 of this window (lines 1 and 2 have the sample settings)

In your case you have an EKM iSerial (select iSerial) and an EKM Omnimeter (select v.3 meter type). Put in the IP address that you have chosen : 192.168.1.125

Click "Save"

3. Go back to the main window.

Enter your meter number in the field next to the "Read One Meter" Button. Enter 3 in the COM# field (this is because you entered the Communications Device details on line 3 of the COM Port Setup window).

Click "Read One Meter".

The details of your meter reading will fill into the main section in the middle of the window. Wait until it is finished updating before you click "Read One Meter" again.

4. Enter the meter details in the lower listbox.

Use COM# or TCP# 3 , Give your meter a name, and be sure the Meter Number is correctly filled in. Select "Save" from the upper menu. Add more meters by selecting "Add Row Below" under "Edit" in the upper menu bar.

Click "Read all meters"

Each meter will be read in turn from the lower listbox. A successful read will mark an "OK" an unsuccessful read will mark an "!!" or and "X"

Select "Save" again (always a good idea)

Let us know if you have any questions.

Best regards,
Jameson
EKM METERING
http://www.ekmmetering.com
831.425.7371

Wouter
Posts: 11
Joined: Sun May 20, 2012 11:37 am

Re: TCP Socket Failed to Connect

Post by Wouter » Fri May 25, 2012 2:05 pm

Once again... Thanks.

I got it working. In preferences I used "HTTP://192..." Don't know why.


When I switched it to "192.168..." it worked. My mistake.


Wouter

Post Reply