Omnimeter Pulse v4 firmware update?

General questions and discussions focused around the EKM Metering System. Discuss your meters, installations, and meter communications here.
Post Reply
Posts: 17
Joined: Sat Mar 21, 2015 9:38 pm

Omnimeter Pulse v4 firmware update?

Post by jaholmes »

Hello! I have an Omnimeter Pulse v4 that periodically runs into what I believe to be an old bug. Every once in a while we'll have a power failure, or a brief power glitch of some sort, and the Omnimeter will stop counting. It can be on, displaying a count, but the count will no longer increment. The solution is always to switch it off and back on. I'm fairly certain I read a post years ago about this being a known issue that was fixed with a firmware update. IIRC, it's also not possible to update the firmware in the field. Can I still send my unit in to be updated?

Posts: 861
Joined: Fri Nov 04, 2011 7:42 pm
Location: Santa Cruz, CA

Re: Omnimeter Pulse v4 firmware update?

Post by Jameson »

Hello Aaron,

Yes you can ship us your meter and we can upgrade the firmware for you for free.

You can send the unit back with a note explaining the issue. When it arrives we can check it out. Please make sure it arrives here well packaged.

Please print out this .pdf form, fill it out completely, and include it with your product:

Please ship to:

EKM Metering Inc.
122 Benito Ave
Santa Cruz, CA


Can you tell us your meter number or firmware version? Is it connected to a Push3 gateway? It sounds reminiscent of an issue we called the "Seasons Lockup Issue" (circa 2014). Here is what we sent out to customers at that time:

Email from 2014 (pre Push3, so it does not mention that you could use a Push3 to make this setting change):

There is a setting in the meter that keeps track of what season the meter is in. The issue is that when there is no season set in the meter, it can behave in unexpected ways. Unfortunately our most recent batch of meters did not have the season preset at the factory. We recommend that you take the following steps to correct this problem.

There is an easy fix but it requires that you change this setting in the meter using the EKM Dash software and either a USB Converter or the iSerial Converter.

To make the change you must first connect to the meter with your computer and start to read your meter. Then go to Meters > Edit Meter > Rates > Seasons Tab. Set the Season to "Schedule 1" with a start date of January 1st (just like the attached screenshot), then be sure to click the "Set" button and enter the meter password (default meter password is "0"). The dash will then indicate that the meter has taken this setting and you should be good moving forward.
Post Reply