Page 1 of 1

Bad Connection to EKM Push Database

Posted: Tue Jul 13, 2021 8:43 am
by pvanmastrigt
Dear Jameson/forum members,

I get a persistent error "Bad Connection to EKM Push Database" in the activity column of EKM Dash.

1.) The internet connection is good.
2.) Pulling up a web-browser with the EKM widget shows fresh data is available in the database and the graphics are up to date in that widget.
3.) There has been a few occasions where some 100 or so reads were pulled. The interval has been something of the order of over one week. Thereafter and in-between the error persists again.
4.) I have tried restart computer/restart EKM Dash / different wifi network but I am quickly running out of ideas what to do here.

Any support / ideas appreciated,

With regards,
Piet van Mastrigt

- MacBook Air 2010
- MacOS High Sierra 10.13.6
- EKM Dash 2.2.4

This system has been working without problems with for extended periods. This "new state" started recently when I moved the system from a location in Kuala Lumpur to a location in Gouda, the Netherlands. Nothing else was changed other than the wifi and its corresponding password

Re: Bad Connection to EKM Push Database

Posted: Tue Jul 13, 2021 11:23 am
by pvanmastrigt
Resolved! Not quite sure what made the difference, but this is what I found:

1.) Google search engine comes up with fresh results when I look for anything - just random search gives new results, however,
2.) Many pages return an error in Safari "safari can't find the server"
3.) Testing EKM Dash on another Macbook Pro (M1 chip)- worked with no problem.

Conclusion: problem was with this MacBook Air 2010, and all else is working.

I changed the WiFi profile to something else (same wifi network/same password, no clue what really made the difference, but the advanced settings are substantially different, including specified IP addresses for the DNS servers which are also different) ét voilà: works.

So how did the Macbook Pro figure out this change - because both moved along from KL? This may be the clue: wifi --> network preferences --> location: "automatic". I think automatic may be the best choice to avoid this issue when moving to other locations.

Not sure if this at all of any help to anyone, but mystery solved for me.