Read iSerial v.4 suddenly stopped

For more advanced meter data users. Learn from others and ask questions about how to read meters, how to use the EKM Push Data, and how to display the meter data in useful ways.
Post Reply
dandelot
Posts: 21
Joined: Fri Sep 05, 2014 7:07 pm

Read iSerial v.4 suddenly stopped

Post by dandelot »

Been reading water data (my own code, C) since 2014.
Linux, Ubuntu 20.04. All been working perfectly.

iSerial has a static IP on my local net. Ping to it works.

Omnimeter Pulse v.4
iSerial v.2

Since February 25 2022, 8:30AM (PST) writing a request to iserial
seems to still work, but read fails.

I switched to calling select() as an
experiment [because the code in
use for years hangs forever on read now] and that select() times out after the
timeout (I set to 5 seconds) returning 0 (the input fd is usually
6) so the iSerial is never 'ready'.

The code in use till the select() experiment just delayed one
second after the write and did a read...which used to work.

EKM Dash (installed latest 64bit version yesterday) says
it gets no response from the iSerial

Could iSerial have developed a fault? Lost some setting
in a power outage here (near San Francisco)? (the UPS
it takes power from is a few years old...).

Any hints? Suggestions for testing?
Thanks in advance.
David Anderson
Attachments
ekmsetupax1000.jpg
ekmsetupax1000.jpg (320.63 KiB) Viewed 1694 times
Jameson
Posts: 810
Joined: Fri Nov 04, 2011 7:42 pm
Location: Santa Cruz, CA
Contact:

Re: Read iSerial v.4 suddenly stopped

Post by Jameson »

From everything you describe I would guess there is some issue with the iSerial. In your photo all 3 LEDs are on at the same time, are they always on? If so, this would also indicate an issue with the iSerial in my experience.

Are you able to login to the iSerial web browser? Are you able to sniff RS485 traffic on the RS485 bus?
Jameson
EKM METERING
http://www.ekmmetering.com
831.425.7371
dandelot
Posts: 21
Joined: Fri Sep 05, 2014 7:07 pm

Re: Read iSerial v.4 suddenly stopped

Post by dandelot »

With instructions from ekmmetering (Seth) to reset the iSerial, I set it up with my info (static ip and the serial settings
from the original iSerial documentation pages).

Attached it to power, ethernet, and the Pulse and it all works now (and so does my reader software).

Both EKM Dash (latest 64bit) and my software working now.

And just as you surmise, Jameson, now that it is working the ACT light is off.
Yes all three were on at once (while it was broken).

Now I can get back to finding the slow water leak in the irrigation system...
DavidA
Post Reply