iSerial Read Data Error

General questions and discussions focused around the EKM Metering System. Discuss your meters, installations, and meter communications here.
vdoshi
Posts: 13
Joined: Sat Sep 22, 2012 1:55 am

iSerial Read Data Error

Post by vdoshi » Sat Sep 22, 2012 2:36 am

Hi,
I'm trying to read my 2 Omnimeter II UL v.3 via iSerial and when I use EKM Dash, I get a "Read Regular Data Error" for each meter.
I have changed the IP of the iSerial device and am able to access it from the PC. I have changed the UART baud rate to 9600. I have connected Terminal A from the meter to Terminal T+ on the iSerial and Terminal B on the meter to Terminal T- on the iSerial. I have set the meter number as the S/N number from each meter. On the meter, both connections are on the left hand side connector (terminals 3 & 2 respectively). I also do not get any blinking on the ACT LED on the iSerial.
I have tried connectin to the iSerial device via serial (local) and via TCP/IP (remote), but both give the same result.
I tried the VCOM software to detect the iSerial device, but it cannon find a device...however, I am able to reach it via the browser.
The problem is that I cannot tell whether the iSerial is receiving data from the meters or the PC is not able to connect to the iSerial.

Any help or suggestions are welcome.

vdoshi
Posts: 13
Joined: Sat Sep 22, 2012 1:55 am

Re: iSerial Read Data Error

Post by vdoshi » Sat Sep 22, 2012 2:41 am

As per the instructions I'm supposed to connect RS485 terminal A+ on the meter to terminal T+ on the iSerial and RS485 terminal B- on the meter to terminal T- on the iSerial. However, I can only see terminals A & B for RS485 on the meter. I'm not sure where the + & - are comming from. Have I connected the meter correctly?

Seth
Posts: 17
Joined: Mon Dec 05, 2011 1:40 pm

Re: iSerial Read Data Error

Post by Seth » Mon Sep 24, 2012 1:40 pm

A and A+, as well as B and B- are interchangeable.

Thanks!

Jameson
Posts: 785
Joined: Fri Nov 04, 2011 7:42 pm
Location: Santa Cruz, CA
Contact:

Re: iSerial Read Data Error

Post by Jameson » Mon Sep 24, 2012 3:28 pm

It sounds like you are really close.

It also sounds like the iSerial is seeing your meter read requests (the ACT light is flashing which indicates RS-485 traffic). This is a good start.

2 things to check first:

What meter number are you using? Are you using the EKM-Omnimeter number that is laser marked right below the LCD screen? Will you please email us a screenshot of your meter setup screen?

Have you changed any of the other UART serial settings in the iSerial? Will you send us a screenshot of this as well?

It sounds like you have the RS-485 date wires properly connected. You can email us a digital photo of how the communication wires enter the iSerial and how they enter the 2 Omnimeters so we can look it over for you.

Best regards,
Jameson
EKM METERING
http://www.ekmmetering.com
831.425.7371

vdoshi
Posts: 13
Joined: Sat Sep 22, 2012 1:55 am

Re: iSerial Read Data Error

Post by vdoshi » Tue Sep 25, 2012 6:35 am

Hi,
Thanks for the reply.
First of all, the ACT lights are NOT flashing, so I'm assuming I have a problem there. I will send you images of the wiring and screenshots of the software setup shortly.
Thanks.

vdoshi
Posts: 13
Joined: Sat Sep 22, 2012 1:55 am

Re: iSerial Read Data Error

Post by vdoshi » Tue Sep 25, 2012 7:21 am

Hi,
Please find attached the screenshots of the UART Setup screen, the EKM Meter setup and the EKM Dash. I will post the images of the physical wiring as soon as possible.
Thanks,

Vishal
Attachments
EKM Dash.jpg
EKM Dash
EKM Dash.jpg (46.75 KiB) Viewed 9895 times
EKM Dash Meter Setup.jpg
EKM Dash Meter Setup. Meter number is 000010001296
EKM Dash Meter Setup.jpg (56.69 KiB) Viewed 9895 times
UART Settings on iSerial.jpg
UART Settings on the iSerial
UART Settings on iSerial.jpg (121.22 KiB) Viewed 9895 times

Nevland
Posts: 65
Joined: Tue Jul 31, 2012 2:56 pm
Location: Nevada City CA

Termination ?

Post by Nevland » Tue Sep 25, 2012 2:50 pm

you might try terminating the 485 terminals at the meter. Mine will not work without the termination.
I have definitely determined this. Someday I might get a chance to investigate this further.
Those little screws on the meter make it hard to experiment however.

Needs DC path A to B ?? Unterminated voltage to high ?? Just some of my guesses. Transmission line was only 3ft
(1 meter) long during my testing, doubt that it had refection problems.

Bill

Jameson
Posts: 785
Joined: Fri Nov 04, 2011 7:42 pm
Location: Santa Cruz, CA
Contact:

Re: iSerial Read Data Error

Post by Jameson » Tue Sep 25, 2012 3:33 pm

Thanks for your input Bill, it is very much appreciated. Would love to get some dialogs going on the forum.

--

I am not seeing a glaring issue in the setup of the EKM Dash or the iSerial that you have sent. It is set to once a minute which will make the setup a little harder.

I would try setting the Dash to read your meters "As fast as possible" for a while. This will read your meters once a second. The ACT light on the iSerial should flash once a second (once for every read). Let us know if the ACT light does not flash.

The settings that you show in your iSerial look good. Besides changing the IP address in the iSerial, are there any other changes that you made? Is it still set to be a server?

I will be interested to see the photos of how the RS485 data wire is connected.

Thanks,
Jameson
EKM METERING
http://www.ekmmetering.com
831.425.7371

vdoshi
Posts: 13
Joined: Sat Sep 22, 2012 1:55 am

Re: iSerial Read Data Error

Post by vdoshi » Wed Sep 26, 2012 2:24 am

Hi Guys,
Thanks for your comments. I'll try terminating all the meters are the iSerial device and I'll try increasing the meter reading to "as fast as possible". In the mean time, attached are some pictures of my physical connection.
Just a note, the distance between the iSerial device and the first meter is approximately 12 meters. Would that cause a problem?
Attachments
1DSC00862.jpg
iSerial Device connection from Meter 1
1DSC00862.jpg (150.01 KiB) Viewed 9880 times
1DSC00858.jpg
Meter 2 connected to Meter 1
1DSC00858.jpg (143.18 KiB) Viewed 9880 times
1DSC00854.jpg
Meter 1 connected to iSerial Device and Meter 2
1DSC00854.jpg (94.35 KiB) Viewed 9880 times

Jameson
Posts: 785
Joined: Fri Nov 04, 2011 7:42 pm
Location: Santa Cruz, CA
Contact:

Re: iSerial Read Data Error

Post by Jameson » Wed Sep 26, 2012 1:19 pm

Hello Vishal,

From the photos you have posted, it looks like you have the meters and the iSerial connected correctly (assuming you have good contact between the terminal blocks and the twisted-pair wire.) To make sure you have a good connection, it is best to back out the terminal block all the way, then insert your bare wire, then tighten the terminal block screw back down.

We would still like to know if the ACT light is flashing on the iSerial. If it is not flashing the problem is before the iSerial. If it is flashing once a second (once per read) and your meters are not being read, then the problem is after the iSerial on the RS485 side.

Thanks,
Jameson
EKM METERING
http://www.ekmmetering.com
831.425.7371

Post Reply